# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\d+\.)\h+(\d+)/$1$2/gm;t' <<< "EB:3668. 19KWh DB:22. 29KWh
EB:3668.19KWh DB:22.29KWh"