using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"const ([a-zA-Z]+) = \(?[a-zA-Z,= ]+\)? =>.*";
string input = @" const validateFadvRequestType = requestType => {
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}