$re = '/const ([a-zA-Z]+) = \(?[a-zA-Z,= ]+\)? =>.*/';
$str = ' const validateFadvRequestType = requestType => {
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);