$re = '/\d+\s*x\s*\d+(?:\s*x\s*\d+)?/m';
$str = '120 x 80 x 100
120x80x100
120x80
120 x 80';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);