#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:https?://)?(?:www\.)?(?:i\.)?imgur\.com/(?:gallery\/)?[a-zA-Z0-9]{7}(?:\.[a-zA-Z]{3,4})?"
Local $sString = "https://i.imgur.com/123/123/123.extension" & @CRLF & _
"" & @CRLF & _
"https://i.imgur.com/jjwgT7i.jpg" & @CRLF & _
"" & @CRLF & _
"https://i.imgur.com/gallery/jjwgT7i.jpg" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"// Imgur no gallery" & @CRLF & _
"(?:https?://)?(?:www\.)?(?:i\.)?imgur\.com/[a-zA-Z0-9]{7}\.[a-zA-Z]{3,4}" & @CRLF & _
"" & @CRLF & _
"// Ingur with gallery" & @CRLF & _
"(?:https?://)?(?:www\.)?(?:i\.)?imgur\.com/(?:gallery\/)?[a-zA-Z0-9]{7}(?:\.[a-zA-Z]{3,4})?"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")