package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:https?://)?(?:www\.)?(?:i\.)?imgur\.com/(?:gallery\/)?[a-zA-Z0-9]{7}(?:\.[a-zA-Z]{3,4})?`)
var str = `https://i.imgur.com/123/123/123.extension
https://i.imgur.com/jjwgT7i.jpg
https://i.imgur.com/gallery/jjwgT7i.jpg
// Imgur no gallery
(?:https?://)?(?:www\.)?(?:i\.)?imgur\.com/[a-zA-Z0-9]{7}\.[a-zA-Z]{3,4}
// Ingur with gallery
(?:https?://)?(?:www\.)?(?:i\.)?imgur\.com/(?:gallery\/)?[a-zA-Z0-9]{7}(?:\.[a-zA-Z]{3,4})?`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}