const regex = new RegExp('(?:https?://)?(?:www\\.)?(?:i\\.)?imgur\\.com/(?:gallery\\/)?[a-zA-Z0-9]{7}(?:\\.[a-zA-Z]{3,4})?', 'gm')
const str = `https://i.imgur.com/123/123/123.extension
https://i.imgur.com/jjwgT7i.jpg
https://i.imgur.com/gallery/jjwgT7i.jpg
// Imgur no gallery
(?:https?://)?(?:www\\.)?(?:i\\.)?imgur\\.com/[a-zA-Z0-9]{7}\\.[a-zA-Z]{3,4}
// Ingur with gallery
(?:https?://)?(?:www\\.)?(?:i\\.)?imgur\\.com/(?:gallery\\/)?[a-zA-Z0-9]{7}(?:\\.[a-zA-Z]{3,4})?`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}