$re = '/{(\w+)}\n([^}]*)/';
$str = '\\eq{\\label{LABEL}
data1
data2
}';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);