#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)([\d]{1,2})\s+([\w]+)\s+([\d]{4})\s+-\s+([\d]{1,2})\s+([\w]+)\s+([\d]{4})\s+([\d]{1,2})\s+N[a,ä]chte\s+([.\s\S]+)\s+DERTOUR"
Local $sString = "Mit freundlichen Grüßen" & @CRLF & _
"i.A. Center Parcs Europe N.V." & @CRLF & _
"Tel.: 0221-97303042" & @CRLF & _
"Fax: 0221-97303019" & @CRLF & _
"EMail: dertour@groupepvcp.com" & @CRLF & _
"Vertragspartner: Center Parcs Europe N.V.; Korrespondenzadresse: Kaltenbornweg 1-3, 50679 Köln" & @CRLF & _
"Geschäftsführer: Pascal R.L. Ferracci, Mark David Haak Wegmann" & @CRLF & _
"Von: ltr-staedte.fra@dertouristik.com <ltr-staedte.fra@dertouristik.com>" & @CRLF & _
"Gesendet: Montag, 4. Juli 2016 14:07" & @CRLF & _
"An: PVCP, Dertour" & @CRLF & _
"Betreff: ADVISING=2016/07/04, SeqNo=738, RefNo=201607042684" & @CRLF & _
"CPNK§" & @CRLF & _
"Center Parcs Nordseeküste GmbH" & @CRLF & _
"Attn.: Frau Schwamborn" & @CRLF & _
"Kaltenbornweg 1-3" & @CRLF & _
"D-50679 Köln" & @CRLF & _
"BRV10888 Center Parcs Park Nordseeküste" & @CRLF & _
"-- OK gebucht --" & @CRLF & _
"DER-REF.: 671509446-3 RES-DAT.: 04 JUL 2016" & @CRLF & _
"Personen: 6 Erw." & @CRLF & _
"Kopie" & @CRLF & _
"01 X BK792" & @CRLF & _
"( EUR 917.60 )" & @CRLF & _
"08 JUL 2016 - 15 JUL 2016 7 Nächte" & @CRLF & _
"Bestätigt nach Anfrage" & @CRLF & _
"Frau MENTHE/URSULA" & @CRLF & _
"Herr MENTHE/CHRISTOPH" & @CRLF & _
"Herr MENTHE/HEIKO" & @CRLF & _
"Frau MENTHE/CHRISTINA" & @CRLF & _
"Kind MENTHE/SILJA (08)" & @CRLF & _
"Kind MENTHE/JANDRIK (04)" & @CRLF & _
"BRV10888 Center Parcs Park Nordseeküste" & @CRLF & _
"-- Bitte stornieren --" & @CRLF & _
"DER-REF.: 671509446-2 RES-DAT.: 29 JUN 2016" & @CRLF & _
"Personen: 6 Erw." & @CRLF & _
"Kopie: kein komplettes Storno - nur Umbuchung auf Termin 08.-15.07." & @CRLF & _
"01 X BK792" & @CRLF & _
"( EUR 1,359.20 )" & @CRLF & _
"08 JUL 2016 - 18 JUL 2016 10 Nächte" & @CRLF & _
"Freesale" & @CRLF & _
"Frau MENTHE/URSULA" & @CRLF & _
"Herr MENTHE/CHRISTOPH" & @CRLF & _
"Herr MENTHE/HEIKO" & @CRLF & _
"Frau MENTHE/CHRISTINA" & @CRLF & _
"Kind MENTHE/SILJA (08)" & @CRLF & _
"Kind MENTHE/JANDRIK (04)" & @CRLF & _
"DERTOUR GmbH & Co. KG" & @CRLF & _
"Erlebnisparks FAX: 069/9588-5122" & @CRLF & _
"++ ENDE AVIS ++"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")