re = /(\S+?),(?=\S+)/m
str = 'SELECT
di.QuestionSetID AS SectionID,
di.QuestionSetID AS SectionID2
,di.ScoreNBR AS Section,LowestTopBoxNBR
,di.AveragePercentileNBR AS SectionTopBoxPercentileRankNBR
,qdate.Quarter,StartDTS AS Section,StartDTS
FROM NRCPicker.PatientSatisfaction.DimensionPercentile AS di
INNER JOIN ('
subst = '$1 '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result