use strict;
my $str = '$index 57320
$title The vertex-cover polynomial of a graph
$time 1988
$abstract In this paper we define the vertex-cover...
$index 57321
$title Locating stations on rapid transit lines
$time 1978
$index 57322
$title Fast heuristics for large scale covering-location problems
$time 1998
$abstract We propose fast heuristics for large scale...
$index 57323
$title Efficient vector processing on dataflow supercomputer SIGMA-1
$time 2001
$abstract Efficiency in vector handling is the key to obtaining high... ';
my $regex = qr/(?<!^)[ \t]*\r?\n(?=\$)/mp;
my $subst = ',';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";