import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\sF\\d+.*?\\n\\n)\\K(\\n)";
final String string = "A N K U N F T 11.08.15\n"
+ "*** NEUBUCHUNG ***\n"
+ " 11.08.15 xxx xxx X3 2830 14:25 17:50\n"
+ " 18.08.15 xxx xxx X3 2831 18:40\n"
+ " F882129 dsdsaidsaia\n"
+ " F882129 xxxyxyagydaysd\n\n\n\n"
+ "A N K U N F T 18.08.15\n"
+ "*** NEUBUCHUNG ***\n"
+ " 11.08.15 xxx xxx X3 2830 14:25 17:50\n"
+ " 18.08.15 xxx xxx X3 2831 18:40\n"
+ " F881554 ZXCXZCXCXZCCXZ\n"
+ " F881554 xcvcxvcxvcvxc\n"
+ " F881554 xvcxvcxcvxxvccvxxcv\n\n\n\n"
+ "11.08.15 xxx xxx X3 2830 14:25 17:50\n"
+ " 18.08.15 xxx xxx X3 2831 18:40\n"
+ " F881605 xczxcdfsfdsdfs\n"
+ " F881605 zxccxzxzdffdsfdx";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}