import re
regex = re.compile(r"\b(\w+)\b(\s\1)+")
test_str = "Esse eh eh um texto texto texto de de um gago gago que que que que nao consegue consegue falar falar direito direito, entao estou estou corrigindo o texto texto texto texto texto pra ele ele."
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)