import Foundation
let pattern = #"^(\([A-Z]\([0-9]\)[A-Z]\([a-z0-9]{20,28}\)\))\/?(.*)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"(X(1)S(4142eh3owtmwtoztdvvz45wo))/contact-us"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
    let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
    print(result)
} else {
    print("No matches were found.")
}