re = /\byou+()|u+s/
str = 'you youyou youyouyou u uu uuu Can\'t wait to see youuuu uuuuyou youuuuuyou uuyouuu you you youyou youyouyou u uu uuu Can\'t wait to see youuuu uuuuyou youuuuuyou uuyouuu
I want to film the bayou with you and put it on youtube,'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end