package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(Price\d+)`)
var str = `Price1
Price2
Price3`
var substitution = "COALESCE(\1, 0)"
fmt.Println(re.ReplaceAllString(str, substitution))
}