package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([^\S\r\n])\}\n[^\S\r\n]*else[^\S\r\n]*\{`)
var str = ` }
else {
Write-Warning
}
else {
Write-Warning`
var substitution = "$1} else {"
fmt.Println(re.ReplaceAllString(str, substitution))
}