import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([^\\S\\r\\n])\\}\\n[^\\S\\r\\n]*else[^\\S\\r\\n]*\\{";
final String string = " }\n"
+ " else {\n"
+ " Write-Warning\n\n"
+ " }\n"
+ " else {\n"
+ " Write-Warning";
final String subst = "$1} else {";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}