#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?sx)(?sx)" & @CRLF & _
"(?| " & @CRLF & _
" \/R.\w*\/(?=.*(\/r\/))" & @CRLF & _
" |" & @CRLF & _
" \/C.\w*\/(?=.*(\/c\/))" & @CRLF & _
" |" & @CRLF & _
" \/M.\w*\/(?=.*(\/m\/))" & @CRLF & _
" |" & @CRLF & _
" \/T.\w*\/(?=.*(\/t\/))" & @CRLF & _
")"
Local $sString = "/Ramon/ /Cesar/ /Murilo/ /Tiago/"
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)