Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
r"
(?P<assign_op>(\:|\!|\?)?=)|(?P<token_subst>$|%(\<\@))|(?P<token_ident>[\w\d\.\,]+)|(?P<target_name_match>%\.?)|(?P<token_rule_sep>[:])|(?P<incr_op>\n)|(?P<line_end>\n)|(?P<comment_op>#[.*]+$)|(?P<adjust_parser>[\$%\s\t\:])
"
gm
Input 1
1
New
CC := nasm BOOT_REQ := text.o FREELDR_SRCS := freeldr.c IMG_NAME := boot.img TEXT_SECTION := 7c00 # UFS2, ZFS and/or RAW FILESYSTEMS := CPU_FLAGS := PAE SDK_FLAGS := VERSION := "1.00.00" %.o: $(ASM) ${SDK_FLAGS} -f bin -o $@ $(patsubst %.bin,%.asm,$@)) ${IMG_NAME}: $(BOOT_REQ) $(FREELDR_SRCS:.c=.o)