using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[(?P<id>[\d.]+)\]";
string input = @"[2.1.1.1] M_1.0_4.1.6.1: A requirement, may have any types ""of symbols."" ::==
And multiple lines describing futher information about this requirement.
With the possibility of being completely empty, placeholders should not match.";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}