import re
regex = re.compile(r"\[(?P<id>[\d.]+)\]")
test_str = ("[2.1.1.1] M_1.0_4.1.6.1: A requirement, may have any types \"of symbols.\" ::==\n\n"
"And multiple lines describing futher information about this requirement.\n\n"
"With the possibility of being completely empty, placeholders should not match.")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")