// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\[(?P<id>[\d.]+)\]").unwrap();
let string = "[2.1.1.1] M_1.0_4.1.6.1: A requirement, may have any types \"of symbols.\" ::==
And multiple lines describing futher information about this requirement.
With the possibility of being completely empty, placeholders should not match.";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}