use strict;
my $str = 'FIRST CASE:
2019-10-02 10:59:31.725 16083 WARNING tripleoclient.v1.tripleo_deploy.Deploy [ ] tripleo-container-image-prepare : Run tripleo-container-image-prepare logged to: /var/log/tripleo-container-image-prepare.log - 911.14s
SECOND CASE:
2019-09-30 08:51:23 | tripleo-container-image-prepare : Run tripleo-container-image-prepare logged to: /var/log/tripleo-container-image-prepare.log 4335.64s
';
my $regex = qr/Run.*tripleo-container-image-prepare.log\s*\-?\s*([1-9]*\.?[1-9]*)s/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}