package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:city|route)=(\w+)(?:\(|\-)(\w+)(?:\,|\;)(\w+)`)
var str = `city=A(100,80);
city=B(160,70);
city=C(110,50);
city=D(140,120);
city=F(155,40);
city=G(210,60);
city=H(190,10);
city=I(170,110);
route=A-C;140;
route=A-D;155;
route=C-F;125;
route=D-B;115;
route=D-I;152;
route=B-F;119;
route=B-G;136;
route=G-F;133;
route=F-H;163;
route=I-H;197;`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}