re = /^-?(?:(?:0|[1-9][0-9]*)(?:,[0-9]+)?|[1-9][0-9]{1,2}(?:,[0-9]{3})+)$/m
str = '123,456,789
-12,34
1234
-8
0,12
1,2,345
0'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end