$re = '/^[<>]?(\d{1,3})(,?1)$/m';
$str = '4.125.583';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);