import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[\\\"\\']([\\a-zA-Z0-9-_]*logo[a-zA-Z0-9\\-_]*\\.(?:png|jpg|jpeg)).*?\"";
final String string = "/example/logo.png\n"
+ "/example/logo_adsadsa.jpg\n"
+ "\"/e/logo_adsada.jpg?size=400\"\n"
+ "src=\"dadsadsadadadadsadasdadsadsalogosdsd.png\"\n\n"
+ "<html>\n"
+ " <head>\n"
+ " <style>\n"
+ " someclass {\n"
+ " background-image: url(\"/css/images/logo2.jpg\");\"\n"
+ " background-color: #cccccc;\n"
+ " }\n"
+ " </style>\n"
+ " </head>\n"
+ " \n"
+ " <body>\n"
+ " <h1>Hello World!</h1>\n"
+ " </body>\n"
+ "<html>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}