#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[a-z0-9]+_reel[0-9]{2}_scn[0-9]{4}_shot[]0-9]{4}"
Local $sString = "" & @CRLF & _
"" & @CRLF & _
"kim_reel05_scn0101_shot0770" & @CRLF & _
"" & @CRLF & _
"n74_reel05_scn0001_shot0700" & @CRLF & _
"" & @CRLF & _
"ninehundred_reel05_scn0001_shot0700"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")