import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[a-z0-9]+_reel[0-9]{2}_scn[0-9]{4}_shot[]0-9]{4}";
final String string = "\n\n"
+ "kim_reel05_scn0101_shot0770\n\n"
+ "n74_reel05_scn0001_shot0700\n\n"
+ "ninehundred_reel05_scn0001_shot0700";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}