#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(\w+ (\w+) (\d+) (\d+:\d+:\d+) (\d+)) (?:\d+ bytes )?From (.+)icmp_seq=\d+ (ttl=\d+ )?(.*)(time=(\d+.\d+) ms)?"
Local $sString = "Tue May 10 10:25:10 2016 64 bytes from egp-tl7794.egp.ap-hop-paris.fr (10.149.219.99): icmp_seq=5 ttl=127 time=1.45 ms" & @CRLF & _
"Tue May 10 10:26:44 2016 From 10.149.219.253 icmp_seq=8 Destination Host Unreachable" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"############" & @CRLF & _
"(\w+ (\w+) (\d+) (\d+:\d+:\d+) (\d+)) (?:\d+ bytes )?From (.+)icmp_seq=\d+ (ttl=\d+ )?(.*)(time=(\d+.\d+) ms)?"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")