use strict;
my $str = 'abcd 1234 abcd';
my $regex = qr/.*/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";