#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = ".*\)\s*(.*)\s*\([mf]\).*"
Local $sString = "Dr. T. (Tom) Bailey (m), UCL- Physics" & @CRLF & _
"Dr. B.K. (Barbara) Blue (f), Oxford - Political Science"
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)