using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*\)\s*(.*)\s*\([mf]\).*";
string substitution = @"\1";
string input = @"Dr. T. (Tom) Bailey (m), UCL- Physics
Dr. B.K. (Barbara) Blue (f), Oxford - Political Science";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}