package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`.*\)\s*(.*)\s*\([mf]\).*`)
var str = `Dr. T. (Tom) Bailey (m), UCL- Physics
Dr. B.K. (Barbara) Blue (f), Oxford - Political Science`
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}