# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"((\d+)th Doctor)(/| & )(.*)"
test_str = ("9th Doctor & Rose Tyler\n"
"9th Doctor & Rose Tyler & Jack Harkness\n"
"9th Doctor/Rose Tyler\n"
"10th Doctor/Rose Tyler")
subst = "\\g<4>\\g<3>\\g<1>"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.