// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"Claim Code:\s*([\w-]+)\s*\$(\d+(?:\.\d+)?)").unwrap();
let string = "Claim Code:
7241B-2HWRXR9-2P2BA
$1.00";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}