$re = '/^(\d{0,7}\.\d{1,4})|(\d{1,7})$/';
$str = '100000';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);