using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d+)-\d+x\d+\.jpg";
string input = @"101018-202x300.jpg 100116-215x300.jpg 1000748-300x157.jpg 100138-196x300.jpg";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}