re = /\/[^\/]+$/m
str = '/docs/one_of_the_resources/one-of-the-resources.html
/docs/a_complete_different_resource/a-complete-different-resource.html'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end