re = /([aeiouy][a-z]+)|(([qwrtpsdfghjklzxcvbnm]+)([a-z]+))/i
str = 'pig
trash
egg
inbox
eight
hello
yahoo
spoonfull
spleen
flea'
subst = '$1$4$3ay'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result