import Foundation
let pattern = #"([aeiouy][a-z]+)|(([qwrtpsdfghjklzxcvbnm]+)([a-z]+))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
pig
trash
egg
inbox
eight
hello
yahoo
spoonfull
spleen
flea
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1$4$3ay"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)