const regex = /<!--FOO-->((?:\n|.)*?)<!--BAR-->/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<!--FOO-->((?:\\n|.)*?)<!--BAR-->', '')
const str = `<!--FOO-->
some text
<!--BAR-->
some other text
<!--FOO-->
some more text
<!--BAR-->`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}