package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?si)(.*\.com)\/[^\/]+(\/prod[^\_]*\/p\.prod).*`)
var str = []byte(`http://www.bergdorfgoodman.com/Ippolita-18k-Gold-Rock-Candy-Mini-Single-Square-Pendant-Necklace/prod108010011/p.prod#.U75MVqY-PtS`)
var substitution = []byte("\1\2")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}