const regex = /(?<=\d),(?=\d)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\d),(?=\\d)', '')
const str = `0:00:22.540,0:00:25.440
Hello this is a test`;
const subst = ` -> `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);