$re = '/batman|(\w+)/';
$str = 'I am ironman and I was batman and I will be superman';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);