re = /<([A-Za-z]{1,7}) .*class='([a-zA-Z0-9_ ]{0,})searchedclass[ '].*>.*<\/\1.*>/i
str = '<div>
<table>
<tr>
<td style=\'abc\' class=\'searchedclass noprint\' style=\'color:#ff0000\'>some random text
</td>
</tr>
</table>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end