#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b(?:Dear|H(?:ello|i))(?:[^\S\r\n]+[A-Z]\w*(?:[’'-]\w+)*\.?)+"
Local $sString = "Hello Mr. Smith" & @CRLF & _
"Dear Mr Smith" & @CRLF & _
"Hello Lisa" & @CRLF & _
"Dear Smith " & @CRLF & _
"Dear Smith-Walker" & @CRLF & _
"Dear Smith Adam Walker" & @CRLF & _
"Dear Smith O'Brian" & @CRLF & _
"Dear Smith O’Brian"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")