re = /\b(?:Dear|H(?:ello|i))(?:[^\S\r\n]+[A-Z]\w*(?:[’'-]\w+)*\.?)+/m
str = 'Hello Mr. Smith
Dear Mr Smith
Hello Lisa
Dear Smith
Dear Smith-Walker
Dear Smith Adam Walker
Dear Smith O\'Brian
Dear Smith O’Brian'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end