// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b(?:Dear|H(?:ello|i))(?:[^\S\r\n]+[A-Z]\w*(?:[’'-]\w+)*\.?)+").unwrap();
let string = "Hello Mr. Smith
Dear Mr Smith
Hello Lisa
Dear Smith
Dear Smith-Walker
Dear Smith Adam Walker
Dear Smith O'Brian
Dear Smith O’Brian";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}